ИНФОРМАЦИЯ

Название модуля (модификатора): Кнопка купить у партнёров - "Buy button from partners"
Версия модуля (модификатора): 1.2
Тип лицензии: Full (полная версия)
Тип установки: ocmod
Язык: Беларуская мова, English, Русский язык, Українська мова
Дата создания: 22.06.2017
Дата обновления: 07.10.2017
Был протестирован на: OpenCart.pro 2.1.0.2.2 и 2.3.0.2.3, OpenCart-"Русская сборка" 2.1.0.2 (rs1), 2.3.0.2 (rs6) и 3.0.2.0 (rs3), ocStore 2.1.0.2.1 и 2.3.0.2.3 - шаблон (default, Revolution, XDS Coloring)
Название архива 1: Buy button from partners v1.0 Full OpenCart 2.X.zip
Название архива 2: Buy button from partners v1.1 Full OpenCart 2.X.zip
Название архива 3: Buy button from partners v1.2 Full OpenCart 2.X-3.0.X.zip


ДЕМО САЙТ
ДЕМО АДМИНКА
Логин: demo
Пароль: demo


ОПИСАНИЕ
Модификатор предназначен для замены названия и ссылки в стандартной кнопке покупки товара, а именно можно выбрать следующие варианты:
- покупка товара на своём сайте - стандартная кнопка;
- покупка товара у партнёра - заменить стандартную кнопку на свою (поменять имя и добавить ссылку на партнёра), по желанию можно вывести несколько кнопок;
- покупка товара у партнёров - заменить стандартную кнопку на кнопку с выпадающим списком партнёров (выводятся имена и добавляются ссылки на партнёров);
- покупка товара у партнёра и на своём сайте - вывод кнопки покупки у партнёра и стандартной кнопки;
- покупка товара у партнёров и на своём сайте - вывод кнопки с выпадающим списком партнёров и стандартной кнопки.


ВНИМАНИЕ!
Оригинальные файлы магазина не заменяет! Всегда проверяйте такие модули (окмоды - архивы) содержащие такие файлы: "install.php, install.sql" так как злоумышленники могут навредить вашему сайту, например, вашими руками удалят вашу базу данных.
Пример запроса (смотрите, чтобы не было удаления таблиц "DROP TABLE": категорий, пользователей, товара и т.д. по оригиналу или всей БД "DROP DATABASE"):

install.php
$this->db->query("DROP TABLE " . DB_PREFIX . "category, " . DB_PREFIX . "user, " . DB_PREFIX . "product и т.д. ");
install.sql
DROP TABLE `oc_category`, `oc_user`, `oc_product`и т.д.;

Модификатор "вносит изменения" в следующие файлы:

Код:
admin/controller/catalog/product.php
admin/language/{belarusian,be-by,by-by}/catalog/product.php
admin/language/{english,en-gb}/catalog/product.php
admin/language/{russian,ru-ru}/catalog/product.php
admin/language/{ukrainian,ua-uk,uk-ua}/catalog/product.php
admin/model/catalog/product.php
admin/view/template/catalog/product_form.{tpl,twig}
catalog/controller/checkout/cart.php
catalog/controller/product/product.php
catalog/language/{belarusian,be-by,by-by}/{belarusian,be-by,by-by}.php
catalog/language/{english,en-gb}/{english,en-gb}.php
catalog/language/{russian,ru-ru}/{russian,ru-ru}.php
catalog/language/{ukrainian,ua-uk,uk-ua}/{ukrainian,ua-uk,uk-ua}.php
catalog/model/catalog/product.php
catalog/view/theme/*/template/product/product.{tpl,twig}


УСЛОВИЯ СОГЛАШЕНИЯ
- Модуль (модификатор) можно устанавливать на 1 домен включая поддомены (одна покупка - один домен);
- Редактировать код можно только под нужды своего магазина;
- Распространение модуля запрещено;
- Тех. поддержка осуществляется только при появлении ошибки, бага, из-за глюка (зависания) и не совместимости модуля (модификатора) с заявленными версиями Opencart и шаблонов на момент продажи;
- Адаптация модуля (модификатора) под другую версию Опенкарта, нестандартный шаблон и сторонние модули - платная.

Написать отзыв
Чтобы написать отзыв, нужно Войти или Зарегистрироваться
Портфолио

700 р.

Продаж
0
Отзывов
0
Продавец - BuslikDrev
BuslikDrev
Информация
Создан
16.06.2018
Совместимость и системные требования
Версия CMS
OpenCart 2.1.x,
OpenCart 2.3.x,
OpenCart 3.0.x,
MaxyStore 2.1.x,
MaxyStore 2.3.x,
ocStore 2.1.x,
ocStore 2.3.x,
OpenCart.PRO 2.1.x,
OpenCart.PRO 2.3.x,
др. сборки OpenCart 2.1.x,
др. сборки OpenCart 2.3.x,
др. сборки OpenCart 3.0.x,
Версия PHP сервера
PHP 5.4,
PHP 5.6,
Языковая локализация
Русский,
Английский,
Адаптивность
Смартфоны,
Планшеты,
Ноутбуки, нетбуки,
Стационарные мониторы,
Совместимость с браузерами
IE 7-8,
IE 9,
IE 10,
IE 11,
Mozilla Firefox,
Opera,
Google Chrome,
Safari,
Яндекс браузер,